Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > BMW SAV Forums > X5 (E53) Forum
Bimmer Tool Rental
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-14-2011, 07:33 AM
Member
 
Join Date: Jun 2010
Location: pasadena, md
Posts: 67
uhenry1 is on a distinguished road
p0135 p0155 p1085 p1083 p174??????

I have a 2001 3.0L that the Check Engine light is coming on. I pulled the codes, but i need some help understanding what it is telling me.

The codes are:
P0171- System too lean (bank1)
P0174- System too lean (bank2)
P1083 - Fuel System too Rich
P1085 - Fuel System too Rich
P0313 -


Now I know that P0171 and P0174 together usually mean an air leak after the mass air flow sensor...or a bad mass air flow sensor. There is no leak or broken tub after the mass air flow sensor. Can anyone help with the "too rich" codes. i dont fully understand this. I had replaced the spark plugs and oil change recently.

Thanks.
Henry
Reply With Quote

Sponsored Links

  #2  
Old 06-14-2011, 12:36 PM
Big "J"'s Avatar
Member
 
Join Date: Feb 2008
Location: Kaufman TX (East of DFW)
Posts: 672
Big "J" is on a distinguished road
Check for a broken butterfly on your DISA valve. Do a search for checking and replacing it.

Good Luck!
__________________
"I canít understand it. I canít even understand the people who can understand it"

Queen Juliana (1909-2004), of the Netherlands

"If you choose not to decide, you still have made a choice!"


2004 X5 4.8is Imola Red-170K ZF-GA6HP26Z
2006 X3 3.0i Mystic Blue-102K, ///M pkg 6-Spd Manual
2003 Silver X5 3.0- sold
2000 VW Beetle 1.8 turbo-145K
Reply With Quote
  #3  
Old 06-14-2011, 12:50 PM
Member
 
Join Date: Jun 2010
Location: pasadena, md
Posts: 67
uhenry1 is on a distinguished road
I did take out the DISA and nothing broken, also check the tub after the MAF, nothing else broken. I did see a leak on the valve cover gasket and I need to replace valve cover gasket. Does the valve cover gasket leak cause the check engine light come on.

Thanks,
Henry
Reply With Quote
  #4  
Old 06-14-2011, 01:00 PM
Big "J"'s Avatar
Member
 
Join Date: Feb 2008
Location: Kaufman TX (East of DFW)
Posts: 672
Big "J" is on a distinguished road
Yes, I believe it can cause codes. Definitely, get it replaced and it should help. Also, I think a failed CCV or oil separator can cause the gasket to fail and throw codes.
__________________
"I canít understand it. I canít even understand the people who can understand it"

Queen Juliana (1909-2004), of the Netherlands

"If you choose not to decide, you still have made a choice!"


2004 X5 4.8is Imola Red-170K ZF-GA6HP26Z
2006 X3 3.0i Mystic Blue-102K, ///M pkg 6-Spd Manual
2003 Silver X5 3.0- sold
2000 VW Beetle 1.8 turbo-145K
Reply With Quote
  #5  
Old 06-26-2011, 09:47 AM
Member
 
Join Date: Jun 2010
Location: pasadena, md
Posts: 67
uhenry1 is on a distinguished road
Hello I need help:

After the dealer replace valve cover gasket and drove over 600 miles, the car run fine until last nite when the drove on the high way suddenly the engine start shaken and shut off. The first time it read code P1352, P0171, and P0174 and then I try to restart the car again, the engine run very rought and shut off, it read P1343, P0171., P0174, P01344, P1352, and P1350. After couple of restart and shut off, I decide to wait about 20 minutes later and restart, the car start rought and I press the gas pedal and started to run Ok, and I was able to made it home without any problems. I check the code, it read P0171, P0174, p1345, and p1343. Could someone place what is wrong with my car. I did check the DISA and look fine. Could the DISA is bad? I know that P0171 and P0174 together usually mean an air leak after the mass air flow sensor but check it out is fine, no broken or leak on the hose.

Thanks,
Henry
Reply With Quote
  #6  
Old 06-26-2011, 11:06 AM
Member
 
Join Date: Mar 2010
Location: Denver, CO
Posts: 428
sunny5280 is on a distinguished road
Quote:
Originally Posted by uhenry1 View Post
Hello I need help:

After the dealer replace valve cover gasket and drove over 600 miles, the car run fine until last nite when the drove on the high way suddenly the engine start shaken and shut off. The first time it read code P1352, P0171, and P0174 and then I try to restart the car again, the engine run very rought and shut off, it read P1343, P0171., P0174, P01344, P1352, and P1350. After couple of restart and shut off, I decide to wait about 20 minutes later and restart, the car start rought and I press the gas pedal and started to run Ok, and I was able to made it home without any problems. I check the code, it read P0171, P0174, p1345, and p1343. Could someone place what is wrong with my car. I did check the DISA and look fine. Could the DISA is bad? I know that P0171 and P0174 together usually mean an air leak after the mass air flow sensor but check it out is fine, no broken or leak on the hose.
A quick and dirty way to test the MAF is to disconnect it and see if the stumbling disappears. Since you appear to have some misfire codes I would also recommend checking the oil separator hoses which are located at the back of the engine underneath the cover. They tend to get soft and can split / crack and cause engine misfire codes.
Reply With Quote
  #7  
Old 06-27-2011, 04:04 PM
Member
 
Join Date: Mar 2005
Location: X5world
Posts: 85
lo7100 is on a distinguished road
you need to get a smoke test to see where is the leak. In my case, the DISA looks fine but failed on the smoke test. There is something that you can't see with your eyes.
Reply With Quote
  #8  
Old 06-27-2011, 04:12 PM
Member
 
Join Date: Jun 2010
Location: pasadena, md
Posts: 67
uhenry1 is on a distinguished road
Hi L0700,

How do you do smoke test or procedure? Any special tool or device and able to do you self. Please help.

Thanks,
Henry
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



I


All times are GMT -4. The time now is 10:53 PM.
vBulletin, Copyright 2014, Jelsoft Enterprises Ltd. Search Engine Friendly URLs by vBSEO 3.6.0
© 2013 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.