Home Forums Articles How To's FAQ Register
Go Back   Xoutpost.com > Electronics > Navigation System
Bimmer Tool Rental
User Name
Password
Member List Premier Membership Search Today's Posts Mark Forums Read


Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-26-2010, 09:09 AM
Member
 
Join Date: Aug 2010
Location: Toledo, OH
Posts: 9
tlynguyen is on a distinguished road
Blank screen - Need Help!

I'm new to this forum. I need some assistance.
I have a 2001 BMW 740i. The navigation display is blank and has white lines flickering on it. The back light works on it. I have been reading this forum and I tried to troubleshoot what is wrong. I believe I have a bad navi computer. I believe I have a MK2 system. The weird thing is that, sometimes it random works for a few minutes and goes back to the blank screen. I have tried to update the OS but no luck. When I put in the disk, the on light just keeps blinking and and the cd in light does not light up. Also, the disk ejects. I'm not very knowledgeable about BMW as this is my first one. I'm trying to fix this myself and at the lowest cost. If anyone out there have any suggestion or advice, I will greatly appreciate it. Thank so much for talking your time reading my situation and thank you in advance for your help.
Reply With Quote

Sponsored Links

  #2  
Old 08-26-2010, 10:07 AM
ccfj1's Avatar
Member
 
Join Date: Sep 2006
Location: The UK.
Posts: 1,882
ccfj1 is on a distinguished road
First off, welcome to the forums.

Second, BMW and Cheap don't go together.

It sounds like either the nav computer is kaput or the TV module (if you have one).

Disconnect the TV module and see if the nav comes back, if not disconnect the nav and reconnect the TV and see if you get the menu on screen.

mk2's are cheap as chips and personally i'd go for a mk3 or mk4, as the mk2 is very dated now.

If its the TV module then 4:3 ones are dirt cheap, $80 should get you one.

HTH

P.S try looking at the plugs on the back of the units as they may be loose (it's worth a shot).
__________________
Sept 03, M3, Silver Grey. Retro-fits: Modded Mk4 DVD Drive, OEM Bluetooth, VR Control, Rainbow Speaker Upgrade, Sony SOT Amp, HK Sub, CCFL, Intravee II, NightMode.
Reply With Quote
  #3  
Old 08-26-2010, 11:26 AM
Member
 
Join Date: Aug 2010
Location: Toledo, OH
Posts: 9
tlynguyen is on a distinguished road
Is the tv module just the front dash with the screen?
Reply With Quote
  #4  
Old 08-26-2010, 12:35 PM
ccfj1's Avatar
Member
 
Join Date: Sep 2006
Location: The UK.
Posts: 1,882
ccfj1 is on a distinguished road
No, thats just a dumb screen, the radio, nav, cd changer and nav are in the boot (trunk).

Post a pic of you front screen to confirm what you have.
__________________
Sept 03, M3, Silver Grey. Retro-fits: Modded Mk4 DVD Drive, OEM Bluetooth, VR Control, Rainbow Speaker Upgrade, Sony SOT Amp, HK Sub, CCFL, Intravee II, NightMode.
Reply With Quote
  #5  
Old 08-26-2010, 01:10 PM
Member
 
Join Date: Aug 2010
Location: Toledo, OH
Posts: 9
tlynguyen is on a distinguished road
Here is the pictures. The white lines on the screen constantly flickers.
Reply With Quote
  #6  
Old 08-26-2010, 01:13 PM
ccfj1's Avatar
Member
 
Join Date: Sep 2006
Location: The UK.
Posts: 1,882
ccfj1 is on a distinguished road
Ok, you have the older style nav unit, you will need to disconnect the Tv an see if that helps.
__________________
Sept 03, M3, Silver Grey. Retro-fits: Modded Mk4 DVD Drive, OEM Bluetooth, VR Control, Rainbow Speaker Upgrade, Sony SOT Amp, HK Sub, CCFL, Intravee II, NightMode.
Reply With Quote
  #7  
Old 08-26-2010, 01:15 PM
Member
 
Join Date: Aug 2010
Location: Toledo, OH
Posts: 9
tlynguyen is on a distinguished road
Do you know what the tv exact look like and how to do it? Thank you so much for all your help.
Reply With Quote
  #8  
Old 08-26-2010, 02:15 PM
Member
 
Join Date: Aug 2010
Location: Toledo, OH
Posts: 9
tlynguyen is on a distinguished road
Also I was wondering, could I use the screen and not the navigation? I just want the radio and cd be display on the screen because my radio sticks off in 2min and 40 seconds. I have to turn it off and on to get it working again. Is there any chance that I don't need the navi to display everything else?
Reply With Quote
  #9  
Old 08-26-2010, 02:20 PM
zeronoo's Avatar
Member
 
Join Date: Feb 2009
Location: Timisoara, Romania
Posts: 94
zeronoo is on a distinguished road
if you have tv module, and the problem comes from navi computer, just disconnect navi computer, all system (except navigation) will work - i assume that BM (board monitor) and cable loom is ok

regards
Reply With Quote
  #10  
Old 08-26-2010, 04:14 PM
Member
 
Join Date: Aug 2010
Location: Toledo, OH
Posts: 9
tlynguyen is on a distinguished road
TO disconnect the navi system, I just take out the disc drive that you insert the map disk in right? Because I did that and now the screen is just blank with no back light. So I'm guessing I don't have a tv module?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



I


All times are GMT -4. The time now is 07:59 PM.
vBulletin, Copyright 2014, Jelsoft Enterprises Ltd. Search Engine Friendly URLs by vBSEO 3.6.0
2013 Xoutpost.com. All rights reserved. Xoutpost.com is a private enthusiast site not associated with BMW AG.
The BMW name, marks, M stripe logo, and Roundel logo as well as X3, X5 and X6 designations used in the pages of this Web Site are the property of BMW AG.
This web site is not sponsored or affiliated in any way with BMW AG or any of its subsidiaries.